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Basic Terms
SAILS
SAILS is a multi-library consortium headquartered in Middleborough. SAILS serves
public, academic, and school libraries in Southeastern Massachusetts communities.

Symphony
Symphony is the name of the library management system used by SAILS libraries.

WorkFlows
WorkFlows is the portion of the Symphony system that library staff members use. The
version of WorkFlows described in this manual is called the WorkFlows Java client .

Enterprise
Enterprise is the name of the online public access catalog used by SAILS libraries.
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Getting Started
Logging into WorkFlows
To log into WorkFlows:

1. Click on the WorkFlows icon located on your computer desktop.
If the following screen appears, click OK. If it does not appear, do not be concerned
about it.
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The Login screen then appears.

2. Enter your library’s User ID and PIN, and click OK.
If you do not know your library’s User ID or PIN, contact an administrator at your
library or contact SAILS.
The User ID and PIN serve several purposes, including:



It defines what features of WorkFlows you can use.
It identifies your computer to your library so that items are checked out
following your library’s circulation policies for loan period, fine rates, etc.
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The WorkFlows screen
After you enter your library’s User ID and PIN, the computer starts WorkFlows. This
may take a minute or two. Then, the WorkFlows screen appears.

File Menu
The File menu can be used to print the contents of the current client window, preview the current
client window, update the staff client, and end the client session. The following options are
available.








Print
Print Preview
Print Screen
Print Setup
Page Setup
Update Staff Client
Exit

Print
Click Print to print the current wizard window. Print templates are defined for some wizard
windows. The print output will include the window title, the date the print job was generated,
and the wizard window data. For some wizards, the print output will include data from multiple
wizard tabs. The standard Windows Print window displays for you to modify as needed before
printing the wizard window. If the current wizard window does not have a defined print
template, the Print command will be unavailable. Use the Print Screen command instead. For a
list of wizards that have defined print templates, see the Print Wizard topic.
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You also have the option of adding the Print wizard (which functions the same as
the Print command) to a toolbar.
The Print wizard must be included in the User Access List of your login for you to
access either the Print command from the File menu or the Print wizard.
In cataloging wizards, the format for printing the current record is controlled by the
Display Bibliographic Description helper properties and selecting File/Print
Preview. For example, if you want the entry labels to print for a bibliographic
record, be sure to select Display Descriptive Labels in this helper. Likewise, if you
want the tag numbers to print, select Display Numeric Tags in this helper.
It is also possible to print glossaries in the Display Bibliographic Description
helper.
On a Windows desktop, it is possible to screen print by pressing SHIFT+PRINT
SCREEN, and pasting the image to a third-party application.
Print Preview
The Print Preview command only works with wizards/windows that have a defined print
template. Click Print Preview to display the wizard data in a preview window. If you click the
Print helper, the standard Windows Print window displays for you to modify as needed before
printing the wizard window. If you click the Close helper, the preview window closes and the
print function is not completed.
The Print Preview command is not available when using Print Screen.
The Print wizard must be included in the User Access List of your login for you to
access the Print Preview command from the File menu.
Print Screen
The Print Screen option allows you to print the contents of the current wizard window. Click
Print Screen, and the contents of the current wizard window are exported to the application
specified in Print Setup for printing and modification (if the selected application is capable of
editing an HTML file). If an application is not specified, the default Internet browser for the
workstation will be used.
Print Setup
Click Print Setup to display the following printing options.


Application to Dump Screen – You can use this option to select an application for
viewing and modifying the contents of a screen print.
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Print to a Printer – Select a printer to be used for printing wizard data templates. Select a
printer from the list. The value you select will be saved to your Desktop Preference. If
you select a printer, the Print to an Application option becomes unavailable.
Print to an Application – Use the Select File gadget to select an application for printing
wizard data templates, such as Microsoft Word. If you select an application, the Print to
a Printer option becomes unavailable.

The Print wizard must be included in the User Access List of your login for
you to access the Print Setup command from the File menu.
This feature is not available when running the WorkFlows client in offline
mode.
Page Setup
Click Page Setup to display configuration options for paper size, print orientation, and margins.
Page Setup applies to printing from a print template. It does not apply to Print Screen
functionality.




Under Paper, select one of the following sizes from the list.
o Letter – Which is 8.5 x 11 inches in size.
Under Orientation, click either Portrait or Landscape.
Under Margins, type values for the Right, Left, Top and Bottom margins, and be certain
to select the appropriate Units from the list. If you selected a printer as a default printer
in the File/Printer Setup menu, the client will try to determine the size and height of the
paper being used in the selected printer and pre-set the margins. (You should verify this
information is correct.)

The Print wizard must be included in the User Access List of your login for
you to access the Print Setup command from the File menu.
Update Staff Client
Click Update Staff Client to update your client as needed. When the update file is successfully
downloaded, you are given the choice to exit the staff client to continue updating, or install the
update later.
Exit
Click Exit to display the following dialog box.
This will halt the workstation.Click Yes to quit the client, or click No to return to the
workstation.
If a toolbar or property has been changed and saved, these values will be retained
for your next workstation session.
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Edit Menu
The Edit menu can be used to manipulate selected text on the current screen. The following
options are available.




Cut
Copy
Paste

Cut
Click Cut to remove the selected information from the current screen and paste the text to the
clipboard. In addition to the underlined shortcut key on the menu, a shortcut for this command is
CTRL+X.
Copy
Click Copy to copy the selected information on the current screen and paste the copy of the text
to the clipboard. The selected text remains on the current screen. In addition to the underlined
shortcut keY.
Paste
Click Paste to put the previously cut or copied text into a field on the current screen. In addition
to the underlined shortcut key on the menu, the keyboard shortcut for this command is CTRL+V.
Note If you copy and paste text that includes line feed and/or carriage return characters, the
client will replace these characters with a couple of space characters

Help Menu
The Help menu can be used to display the Documentation page of the WorkFlows Help, the help
topic associated with the current window, and information about the software. The following
options are available.






Contents
Context
Key Enhancements
Session Information
About

Contents
Click Contents to display the Documentation page of the WorkFlows Help.
Context
Click Context to enable context-sensitive help and display the help topic associated with the
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current window. Context sensitive help can also be displayed by clicking the Help button (book
with question mark) on a toolbar, by pressing the F1 shortcut key, or by right-clicking the mouse
over a wizard icon and selecting Help from the shortcut menu.
It is important to consider the following:





To display help for dialog boxes, press the F1 shortcut key. The Help button cannot be
used to display help for dialog boxes.
If you use the right-click method to access wizard properties, press the F1 shortcut key
to display help.
Context help cannot be displayed for a group wizard icon. Open the group wizard, open
a wizard, and click the Help button for individual wizard topics.
The Help wizard must be included in the User Access List of your login to access Help
from the File menu or from the Help wizard.

Session Information
Click Session Info to display Login information and Host information about the current client
session.
About
Click About to display the software version and the SirsiDynix copyright statement.
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Toolbars
Each toolbar, such as the Circulation toolbar, consists of wizards, grouped into “groups of
wizards.” Select a toolbar by clicking the toolbar name at the top of the client window.

Wizards
A wizard is the feature of WorkFlows that you use to perform a specific task, such as
check out an item, register a patron, or place a hold for an item.
WorkFlows arranges wizards that have similar functions into groups of wizards, such as
Common Tasks, Users, Items, etc., on the left side of the screen. To open or close a group
of wizards, click the open/close icon:

The Common Tasks group of wizards, for example, looks like this:
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To use a wizard, click on the wizard icon or text within the group of wizards. If you are
unsure what a wizard does, move your mouse over the image without clicking. Text will
appear describing the function of that wizard. You may also click on a wizard and then
click on Help and then Context.

For example if you click on Checkout and click on Help – Context this screen will
appear.
You are here: Circul ation > Checkout Wizard

Checkout Wizard
The Checkout wizard is used to check out items to a library user. Depending on how wizard
properties are set and if patron photos are configured to appear for your library, it can also be
used to add a photo to the user's record. This wizard displays on the Circulation, Academic
Reserves, and Outreach Services toolbars.

To check out items
1

Click the Checkout wizard.

2

Do one of the following.
• If the User Search helper is set in properties to display as the first step of the wizard,
search for the user. The helper will automatically fill in the User ID box with the ID
you select using this helper.
• In the User ID box, scan the user’s ID.
•

If the Current button is available, click the button to select the last user record
that was displayed, modified, or added.

• Type the user ID in the User ID box, and click Get User Information.
• Use the User Search helper to search for the user. If a list displays, select the user you
want, and then click Check Out to User.

Note: If your library uses the barcode validation feature, a message appears if you type or scan a
user ID with an invalid barcode format in the User ID field.
3 In the Item IDbox, scan the item ID or barcode.
4

If Cache Item IDs is selected in behavior properties, you can scan multiple item IDs in
this box. Click Check Out Item to User to send all item IDs for check out.

In the List of Checkouts heading, the number of items checked out displays. Under
List of Checkouts, the item’s title, call number, item ID, date due, and item type
display. If the item that is charged results in a
charge fee, the bill amount also displays. If the user has a patron credit account, and the wizard is
configured to pay bills automatically with funds from the credit account, the amount paid from the
credit account displays. Click the item ID glossary to view detailed information about the item.
If you select an item or group of items in the checkouts list and right-click, a circulation menu opens.
5
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From this menu, you can perform a variety of circulation tasks. See Right-click Menus.
6 Repeat step 3 (or 4) until all items are checked out.
7

If Display Email Current Checkouts receipt button is selected in behavior properties,
you can click Email Current Checkouts to email the user a receipt containing information
on the items checked out during this session.
Alternatively, if Display Email All Checkouts receipt button is selected in behavior
properties, you can click Email All Checkouts to email the user a receipt containing
information on all the items checked out to the user.

A confirmation dialog box displays. Click OK.
Note: WorkFlows returns an error message if the user does not have an email address in the user record.
For information on configuring checkout receipt emails, see the Configuring Checkout Receipt Email
Template Files help topic.
If desired, you can add a photo to the user record, or replace the current photo with a new one.
For more information, see Adding or modifying a patron photo.
After you have checked out items to the library user, select one of the following options:
• Check Out to New User to check out items to a new user
• Close to exit the wizard
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Properties
Each wizard has properties which provide window defaults and various control settings for each
wizard. SirsiDynix provides a set of system properties. When a client session is started, the delivered
properties are downloaded to the workstation. Any changes a user makes to properties are saved on
that user’s workstation. The changes will be displayed the next time the wizard is used.
Use these steps to display or modify properties for a specific wizard. Not every log‐in will allow
you to reset properties.
1. Place the cursor over a wizard’s icon/name.
2. Click the right mouse button.
3. Click Properties to display each wizard’s Set Properties window.

If you set properties using the right-click method, when exiting the client, you will be prompted
whether or not to save changes to properties. If properties are set when using the wizard (a left
mouse click), changes are not saved when exiting the client.
If you access properties using the right-click method, press the F1 shortcut key to display help.
The Help button cannot be used to display help for dialog boxes.
Wizard Properties Tabs
Properties may contain the following tabs.





Behavior – On the Behavior tab, you can preset selected field values and select which next
steps and/or tabs will display with a specific wizard or helper. Some wizards will contain an
At End of Wizard screen area, in which you can select which next step buttons display at the
end of the wizard work flow or select which action the wizard should automatically perform
as the last step of the wizard.
Defaults – On the Defaults tab, you can preset field values and select which information will
display with a specific wizard or helper.
Helpers – On the Helpers tab, you can select which helpers will display with a specific wizard
or helper. You can configure properties for helpers by clicking on the button under the helper
name in wizard properties.

Administrators and supervisor-level staff have access to Behavior, Defaults, and Helpers properties.
Other staff have access to only Defaults properties.

Helpers
A helper is a shortcut to a wizard from within another wizard. Helpers appear as small
icons near the top of the screen (see figure). Different helpers appear when you access
different wizards. If a helper is “grayed out,” it is not available for use.
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The Helper bar is positioned horizontally across the top of the WorkFlows client interface, just
below the active window’s title bar. Helpers listed on the left side of the bar primarily make it
easier to access necessary information needed by the current wizard. For example, Checkout
wizard uses the following helpers: Lookup User, Register New User, User Lost Card, Pay Bills,
Add Temporary Title, Confirm Address, Replace Item Barcode, Special Due Date, and Renew
Privilege. If a helper is grayed out then it is not applicable to the task you are performing.

Glossaries
Information underlined with a dashed line will display a glossary when you click it.
. For example, when looking at a list of items checked out to a patron a list of item id’s display.
When one of the items is clicked, a brief checkout displays.
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Gadgets
Indicated by the gadget icon
, these tools make selecting field values easier. These gadgets
can be used to select information such as date and time ranges, policy values, or monetary
amounts. You may use a gadget by clicking the gadget icon with the mouse or by pressing the
TAB key to select the gadget and then pressing ENTER to open it. Gadgets also have contextsensitive help links.

Drop-down Lists
1. Indicated by the arrow icon

, drop-down lists make selecting field values and
policy values easier. The lists present valid values for the wizard fields. Click the arrow

button.
2. Click one of the values in the list to select it.
3. Or, if you start to type a value name, the wizard jumps to that value in the list.
Click the value to select it.
When you start to type a value name, the drop-down list behaves in a standard Windows
manner. When you type a partial match that will always result in a list (for instance, if
you type one letter), you will start in the list at that letter. If you type in three letters, you
will start in the list at the first match for those three letters and be able to scroll down the
list from that point. If you type a whole text string, you would still be able to see the text
strings following it.
For example, these policy names are available: AAA, ABA, ABB, ABC, ABD, and BCD.
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When you type A, the list starts at AAA.
Next, type B, and the list selects ABA.

Notes and Alerts
When WorkFlows displays patron information, any notes from the patron’s record or
alerts, such as those about money owed, appear near the upper left in red.

Click the Notes or Alerts to display this information.
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Sorting
To sort a list of items, click the column heading that you want to sort by. To sort the
column in the opposite direction, click the column heading a second time.
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After sorting, the results would appear as follows:
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Right‐click Menus
The WorkFlows supports right-click menus for wizards and other WorkFlows functions. These right-click
menus are popup or shortcut menus that contain commands and options that can be performed against
a selected record or group of records. The right-click menus are available using a mouse right-click in
circulation lists (or tables), such as checkouts, bills, holds, bookings, and more.
Once in a right-click menu, you can click a circulation or print option, or use CTRL+ the underlined
character to access an option.

Which right‐click menus are available in the WorkFlows client?
The following wizards/functions will display a menu when the user right-clicks within the circulation
lists (tables).
List type
Wizards
Menu options
Bill
Billing a User CheckOut Display User
• Change Item ID
Renew User User Lost Card
• Display Item
• Edit Bill Note
• Edit Item Note
• Pay Bill
• Place Hold
Bill
Paying Bills
• Change Item ID
• Display Item
• Edit Bill Note
• Edit Item Note
• Place Hold
Booking
Display User
• Create Booking
• Display Item
• Edit Item Note
• Modify Booking
• Modify Booking Due
Date
• Remove Booking
Checkin
Discharging Discharging Bookdrop
• Bill User for Item
• Change Item ID
• Display Holds
• Display Item
• Display User
• Edit Item Note
• Mark Item Missing
• Mark Item Used
• Place Hold
Checkin
Fine Free Discharge
• Change Item ID
• Display Holds
• Display Item
• Display User
• Edit Item Note
• Mark Item Missing
• Mark Item Used
• Place Hold
Checkout
Display User User Lost Card
• Bill User for Item
21/

Checkout

Ephemeral

Checkout

Renew Item

Checkout

Renew User

Current

CheckOut Paying Bills

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Change Item ID
Claims Returned
Discharge
Display Holds
Display Item
Edit Item Note
Mark Item Lost
Mark Item Missing
Modify Due Date
Place Hold
Print Checkout Slip
Renew As Seen
Renew As Unseen
Bill User for Item
Display Item
Edit Item Note
Modify Due Date
Print Checkout Slip
Bill User for Item
Change Item ID
Discharge
Display Holds
Display Item
Display User
Edit Item Note
Modify Due Date
Place Hold
Print Checkout Slip
Bill User for Item
Change Item ID
Claims Returned
Discharge
Display Holds
Display Item
Display User
Edit Item Note
Mark Item Lost
Mark Item MIssing
Modify Due Date
Place Hold
Print Checkout Slip
Bill User for Item
Change Item ID
Claims Returned
Discharge
Display Holds
Display Item
Display User
Edit Item Note
Mark Item Lost
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List of

CheckOut

Hold

CheckOut
Display Item Holds Display Title Holds
Display User Holds Paying Bills
Renew User

Hold

Display User User Lost Card

Onshelf Items

Onshelf Items

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Mark Item Missing
Modify Due Date
Place Hold
Print Checkout Slip
Renew As Seen
Renew As Unseen
Bill User for Item
Change Item ID
Discharge
Display Holds
Display Item
Display User
Edit Item Note
Modify Due Date
Place Hold
Print Checkout Slip
Bill User for Hold
Display Item

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Display User
Edit Item Note
Modify Hold
Place Hold
Remove Hold
Reorder Hold Queue
Bill User for Hold
Display Item
Edit Item Note
Modify Hold
Place Hold
Remove Hold
Reorder Hold Queue
Mark Item Missing
Trap Hold
Unfill Hold
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Keyboard Shortcuts
You can use keyboard shortcuts or function keys for data entry, wizard access, and for
entering special characters and diacritics. You can use standard Windows editing
shortcuts, such as:


CTRL + X for cut



CTRL + C for copy, and



CTRL + V for paste.

There are also keyboard shortcuts for each set of wizards. For example for
circulation the following key combinations can be used as short cuts:

Circulation
Use the following keyboard shortcuts to access circulation wizards.
Wizard

Key Sequence

Checkout

F5

Discharge/Checkin

SHIFT+ALT+F6

Fine Free Discharge/Checkin

SHIFT+ALT+F1

Renew User

F7

Renew Item

SHIFT+F7

Bill a User

SHIFT+F8

Pay Bill

ALT+F8

Display User

ALT+F10

New User Registration

F11

Modify User

SHIFT+F11

Copy User

SHIFT+ALT+F10

Confirm Address

ALT+F11

Renew Privilege

ALT+F12

Remove User

SHIFT+F12

Add Items

ALT+F1

Add Brief Title

SHIFT+F1

Change Item ID

SHIFT+F6

Mark Item Missing

ALT+F4
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Mark Item Lost

ALT+F5

Place Hold

F9

Display User Holds

SHIFT+F9

Modify User Holds

SHIFT+F10

Remove User Hold

ALT+F9

Display Title Holds

[No default mapping]

Display Item Holds

SHIFT+F2

Modify Item Holds

ALT+F2

Remove Item Hold

ALT+F3

Trap Holds

SHIFT+F3

User Claims Returned

ALT+F7

User Lost Card

SHIFT+ALT+F8

Modify Due Dates

SHIFT+ALT+F4

Credit User Account

[No default mapping]

Mark Item Used

SHIFT+ALT+F5

Inventory Item

SHIFT+F4

Ephemeral

SHIFT+ALT+F7

Checkin Bookdrop Items

ALT+F6

What’s in Transit

SHIFT+ALT+F11

Receive Items in Transit

SHIFT+ALT+F12

Place Blanket Hold

None

Item Search and Display

F4

Check Item Status

F2

Help

F1

Print

F12

Quitting the Workstation
Use one of the following options to end your workstation session.


Click the Close button in the upper right corner of the main client window.
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On the File menu, click Exit.
Press the shortcut keys ALT+F and ALT+X, in that order.

The client displays the following message.
This will halt the workstation

Click OK to quit the workstation, or Cancel to resume your session.
If properties have been changed, you will be asked whether to save these changes.

26/

